Can-Am Commander Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So i recently did an upgrade to my 2013 Commander. I added the 2" highlifter lift kit with 30" Blackwater on M12 rims. I did not travel more than 125 km ( 78 miles for my american counterparts) before one axle complete came apart at the CV while bending the tie rod while the other axle is not broke, it is in bad shape. Did not think the new set up would be so hard on the axles. I am thinking of getting the Highlifter DHT axles hoping it will solve the issue. Anyone have this happen to them so soon after an upgrade? By adding the new tires and lift, do I require longer axles or will the HD axles suffice? What about aftermarked heavy duty tie rods, any suggestions?
 

·
Administrator
Joined
·
2,344 Posts
So i recently did an upgrade to my 2013 Commander. I added the 2" highlifter lift kit with 30" Blackwater on M12 rims. I did not travel more than 125 km ( 78 miles for my american counterparts) before one axle complete came apart at the CV while bending the tie rod while the other axle is not broke, it is in bad shape. Did not think the new set up would be so hard on the axles. I am thinking of getting the Highlifter DHT axles hoping it will solve the issue. Anyone have this happen to them so soon after an upgrade? By adding the new tires and lift, do I require longer axles or will the HD axles suffice? What about aftermarked heavy duty tie rods, any suggestions?
Hasent been may post here for quite awhile with the lifts and problems. Are you on Facebook?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top