Can-Am Commander Forums banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,424 Posts

·
Registered
Joined
·
305 Posts
Adam, you make it all look so easy. Actually it is. The only thing with mine is, that with the Commander in Park, and the engine running, the Primary is turning the belt and the secondary. Is this as it should be? I thought the belt would just ride on the one way bearing and not spin.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
u have one of the 1st 5 clutches i did for the commanders. thats how long it took me to figure out the alignment difference on the commander versus the outlander. my apologies. i will send you the necessary hardware to fix the belt alignment. all the clutches since marks have all been machined for proper belt alignment. all you need is a shim on the secondary shaft of yours to correct the alignment. i will get them headed your direction
 

·
Registered
Joined
·
126 Posts
Adam, check your email. I'm ready to buy. Just need you to send me the paypal link. Also, I'm getting the aluminum sliders. Will that hurt top end speed? I don't want to lose any top speed. I want to be banging off the speed limiter.
 

·
The Outlaw Ignore Amos
Joined
·
197 Posts
Adam, check your email. I'm ready to buy. Just need you to send me the paypal link. Also, I'm getting the aluminum sliders. Will that hurt top end speed? I don't want to lose any top speed. I want to be banging off the speed limiter.
X2... Im ready when you are...have sent a couple of emails...
 

·
Registered
Joined
·
126 Posts
We were sending emails back and forth last Sunday night. Then I said send me the paypal link, and that was the last I heard from him. I hope everything is ok. I already have everything stripped down because I installed the Therma tec wrap. I was hoping to get the clutch and put it in before I put everything back together.
 
1 - 8 of 8 Posts
Top