Can-Am Commander Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Summary of the Trip:
BrimStone, WindRock and Royal Blue WMA.
Monday Thru Saturday.
425
or so miles Total on the Tails.
11 - 15 hours a day on the trails.
Trail Ratings: Green (Easy) Blue (Moderate to Moderately Difficult) Red (Difficult to Extremely Difficult)

OK, Back from my vacation and I have to say I give my Commander a over B+ Rating. I was able to go any place the guys 2 RZR 900 XPs and 1 RZR 800 S could go with only a few minor issues. Clearance was good with only minor drags (mostly the hitch area) and the suspension worked very well. On flat open roads and trails I was about to run with the 2 RZR 900 XPs and the RZR 800 S easy. Keep in mind this is the first real ride I have done on the Commander and I am still getting use to it. We stuck to Green and Blue Trails. Though part of our group went and did some red trails but seeing that I don't have a winch yet I wasn't going on them because there was winching required on parts of it. On a side note good thing I didn't because one of our group rolled his RZR 800 S down the side of a mountains on a near vertical hill climb and wrapped it around a tree and was life flighted to an area hospital with a broken collar bone and broken ribs with a punctured lung. He is ok but will be out of action for a while. His passenger was knocked out also but did not get hurt and did not go to the hospital. On the bright side his machine was not totaled and will only have to replace the roll cage, some plastic and 2 front axles after it was looked at after being towed back to the cabins.


Over all we all Had a great time and the Commander worked very well with only a few issues.

Commander Issues: (Here are some issue and some thoughts.)

#1: Trail 89 BrimStone Blue Trail Listed as Moderate Difficulty. My Front Diff/4wheel drive Failed to lock up and give power while in 4 Wheel Drive and Low Range. At the first Hill Climb where I had to get over a rock formation at the base of the climb. On the 4th try the front diff./4wheel drive locked in and I went right up and over the rocks on to the hill climb. After that the rest of the trip if seemed to work just fine on all trails.

#2 / #3 First time it was Smoke from leaves being caught between the factory Skid plate and the motor/ exhaust on the drivers side of the Commander after a night of hard wheeling on a very muddy trail on Royal Blue WMA. Second time it was worse because I had Smoke and flames shoot up thru a drain hole on the drives side form the same area. Both times I quick stop and a squirt bottle with water stopped the fire. No damage at all and after I spent 30 minutes both times picking, pushing and pulling leaves out it didn't happen again.

#4 Cooling Face stopped working / Started to over heat then 2 hours later just started working again. As anyone who owns a Commander or just about any side by side knows. The fans are loud and run often when you are running hard or just sitting for to long and the Commander puts off some heat and the face sounds like a jet turbine when it runs. Well, about 40+ miles out from the cabin on the trail. I started to have a over heating issue. My fan stopped working and wasn't running at all. Checked Fuses and Ran the wires but nothing seemed out of place. Radiator was packed with mud but not the back side where the fan is. So out came the squirt bottles and we cleaned it out found a creek and I drove around in 2 feet of water for a bit to clean out everything really good. But the fan still wasn't running. So we hopped on the trial and headed out. As long as I kept moving it was good but when I sat to long or drove under 10 mph it would heat up and start giving me the over heating message and I would have to stop and let it cool down. Well, we hit a nice haul road (coal road) and we ran about 50 mph down it and I didn't have a over heating issue. When we stopped about 7 or 8 miles down the road the fan kicked on and worked fine for the rest of the trip back to the cabin (about 40 miles give or take).

#5 EMP Windshield quick disconnect thumb screws kept backing out. Applied some lock tight and the issue was fixed.

While none of these issues were huge they were kind of annoying. I am having the dealer look at the over heating and diff issue this week along with a servicing it needs. As for the Fire issue I am going to need to replace the factory skip plates ASAP.

Thing I wish I had:

Doors!!!: The Net's suck ass. and when they are muddy or mucked up with heavy dust the seat belt latch wants to not click right out came the squirt bottle of water and problem solved.
4 Point Harness: Again while the factory seat belt works the seat belt latch when muddy or trail dust sticks and is a pain enter the squirt bottle.
Radio: I had no tunes really need to get that sorted would have really added to the fun.







----------







----------



 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 · (Edited)
Here you go folks. Thanx to Kerry West and Mudcon Productions who did the video and was on the ride.

Youtube killed the video due to the sound track used. I am sure it will be reedited soon.
 

·
Premium Member
Joined
·
1,424 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
Next year we (our riding group) are talking about going to either Moab or Hatfield/McCoy. We have not decided which. Hatfield/McCoy is closer but I would love to do Moab.
 

·
Premium Member
Joined
·
1,424 Posts

·
Premium Member
Joined
·
543 Posts
Great job on the write up, pictures and driving.

Didnt see your video, but had the same music problem and have not tried it but what I understand I'd if you don't start music right away and keep all music clips under 30 seconds you might be able to keep you songs you want to use.

The kind of riding all day you are doing you might want to check out the Bad Dawg storage containers for the Commander bed. http://www.commandertalk.com/vip-members-forum/1336-bad-dawg-pricing-no-longer-public-but-still-available.html
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Great job on the write up, pictures and driving.

Didnt see your video, but had the same music problem and have not tried it but what I understand I'd if you don't start music right away and keep all music clips under 30 seconds you might be able to keep you songs you want to use.

The kind of riding all day you are doing you might want to check out the Bad Dawg storage containers for the Commander bed. http://www.commandertalk.com/vip-me...ing-no-longer-public-but-still-available.html

Here is the video readded.

I've looked at them the way they attach using ratchet straps isn't to my liking. Thanx though.
 
1 - 9 of 9 Posts
Top