Can-Am Commander Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
1,988 Posts
Discussion Starter · #1 ·
ok has anyone else had this problem or is it just me....I noticed sometime ago that I had a little squeak with suspension really was never able to trace it for sure, but now it has become a total annoyance, normally I always have my helmet on but last night going over to friends campsite I didn't and it is just plain not acceptable...Thinking it might be coming from the top of the shock tower.
My question is what would be a good product to use to spray to see if it would help...ride mostly in sand but dirt sometime also..or do I need to replace the bushings have about 1500miles on it now...
Thanks for the help in advance...Barbara
 

·
Registered
Joined
·
17 Posts
Had the exact same problem. I just had to touch the cage and it would go CREAK!!! It's the upper shock mounts in the front-- pound the grease to it and let me know how it turns out.
 

·
Premium Member
Joined
·
1,988 Posts
Discussion Starter · #3 ·
THANKS As LBR was reading my posting a light came on...one of the maintenance schedules not sure of mileage says to grease shock towers now to find my book that has a hiding spot and won't let is know where it is
APB put put....lol
Sent from my DROID3 using Tapatalk
 

·
Premium Member
Joined
·
543 Posts
Another thing that creaks it the tie rod ends. You can get the rubber dust covers to put over them so they don't get rusted or get the dust both which would cause creaking or squeaking.
 

·
Premium Member
Joined
·
1,988 Posts
Discussion Starter · #5 ·
Another thing that creaks it the tie rod ends. You can get the rubber dust covers to put over them so they don't get rusted or get the dust both which would cause creaking or squeaking.
Thanks Bryan...we were hanging out with some friends last night shooting the crap and I said This creaking is pissing me off and one of them said it's sounding like it's coming from up here....so that is making me think it's up at shock towers, but will differently check tie rods ..THANKS...Babara:)
 

·
Registered
Joined
·
149 Posts
I had my bed not latched completely once and had a bad rattle/squeek. Might check it out. Looked like it was latched but wasn't - everytime I hit a bump - squeek.
 

·
Premium Member
Joined
·
1,988 Posts
Discussion Starter · #7 ·
I had my bed not latched completely once and had a bad rattle/squeek. Might check it out. Looked like it was latched but wasn't - everytime I hit a bump - squeek.
Thanks will check that...this sounds like it is coming from the front...Lance will check it out this week...
 
1 - 7 of 7 Posts
Top