Can-Am Commander Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I was out on a run with friends and it ran great all day. I arrived home and parked in front of my garage and when I got out I heard the engine stumble and quit. It wouldnt start again and decided to look at it in the light. Next day I got it to start but was hard and I notice raw fuel coming out of the exhaust. So here is what it is doing, rear cylinder injector is on continuously when I crank it. Have both spark plugs out to roll over easier. Took the rear injector right out and put it in a plastic container to watch and sure enough it spews fuel. I took the electrical connector off the forward injector and plugged it into the rear one in the container and works perfectly. Any thoughts would be appreciated. Probably going to get into the harness next to see if there is an issue. Im not really sure how they work electrically, other than its a signal from the ECM but is it ground seeking I dunno. Guess I should also say it has the check engine light on at this time but seemed intermittent as well. Going to ring out the harness anyway. Im also running on tracks right now so am I glad it quit in front of the garage. HELP
2013 1000XT
 

· Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
Problem solved wire bundle was chaffing on the piece of frame it was tyrapped too by the factory. I saw a small hole in the outer protective wrap so I cut that back and found a wire chaffed through, low and behold it alive.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top