Can-Am Commander Forums banner

1 - 8 of 8 Posts

·
Super Moderator
Joined
·
2,339 Posts
Thanx for bringing that over Steve ...will sign when at a real computer .....Lance

...sent with TapaTalk...please excuse brevity & no smileys
 

·
Registered
Joined
·
22 Posts
Glad we are trying to get somewhere with this. I am taking mine to dealer in a few weeks to tell them to come up with a fix or i will hire a lawyer and they can have it back. I am not paying this much money for something that is so noisy. They have a serious problem on there hands with this issue and for us the consumers will have to spend hundreds of dollars in the future if this issue is not resolved soon.
 

·
Registered
Joined
·
18 Posts
Well I called my dealer today and they acted like I was crazy! Told me it would be a week before the could even look at it and up to two more week to find problem and then they would order parts.
So I put my X on the (4 so it's level) stands and pulled the plug for rear diff and took a Qtip bent at a 90 deg and stuck it in. Guess what? It never touched oil,250 miles and no oil. Man I'm pissed called the dealer and talk to GM and told him to ask the kid who put my unit together how much oil he added to front and rear diff.
No back out to check front and gearbox.
 

·
Premium Member
Joined
·
1,988 Posts
I would be taking it right back to the dealer..have him check it and them say please Put fix this problem with NEW diff...the dealer is the one that adds the fluids dealer has 100% responsibility

Sent from my DROID3 using Tapatalk
 
1 - 8 of 8 Posts
Top