Can-Am Commander Forums banner
1 - 14 of 14 Posts

·
Premium Member
Joined
·
1,424 Posts
Most people have their whips wired to a switch and then to the battery.

I thought I had some pictures or mine, however, thinking about it they would do no good as I have a separate fuse panel for all my lights, stereo, navigation, ect.

As far as mounting, if you are running the factory cage I would imagine there are several mounts available, for example:



Axia Alloys

Personally, my mounts are built into my cage...not saying it is better, just a request I had when my cage was built.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Administrator
Joined
·
2,344 Posts
Got my lighting equipment in last week, the shrink tubing in today ....almost time to start "trimming the whip with lights"....Hohoho ....MerryChristmas

Jason ....how long was your Commander whip? ....then you mentioned you almost had enough led light tape for a second whip the same length? ....

I'm guessing that 2-4' whips would be maximum with flags on them ....and wrap at most 3 1/2' on each whip?

sent by my possibly salvagable Droid I

 

·
Administrator
Joined
·
2,344 Posts
I want to say they were 5 and a half feet long and you can make two whips with about two feet of LED strip left over.
Thanx ..I over estimated the length of tape lost by wrapping by alot, huh? ...hehe ....ok, now, off to fix my picture in the post above!

sent by my possibly salvagable Droid I
 

·
Registered
Joined
·
149 Posts
Just curious if anyone has broken their whips yet & what tubing you guys are using. I think mine was a Tribal whip? can't remember but it snapped off when I was going through the whoops my last trip to Sand Mt. I have only used it on 3 trips & have never rolled or flopped it over. It is only like a 4'-5' whip thats mounted on my roll cage. Also curious for those that are making these whips if you are filling the tube with a clear liquid? I noticed when my whip broke some sort of clear fluid was coming out of the tube.
 

·
Premium Member
Joined
·
345 Posts
Just curious if anyone has broken their whips yet & what tubing you guys are using. I think mine was a Tribal whip? can't remember but it snapped off when I was going through the whoops my last trip to Sand Mt. I have only used it on 3 trips & have never rolled or flopped it over. It is only like a 4'-5' whip thats mounted on my roll cage. Also curious for those that are making these whips if you are filling the tube with a clear liquid? I noticed when my whip broke some sort of clear fluid was coming out of the tube.
The whips I make are fiberglass rods with the LEDs wrapped around the outside and covered with clear heat shrink tube. It's all in my video.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top